EnvisioKnit User's Manual

Download a print-friendly version (PDF).

Table of Contents

This manual is a work in progress. It is continuously being improved and revised to reflect the latest version of EnvisioKnit Design Studio. If you feel that anything is missing or unclear, please let us know and we'll be happy to fix it.

In addition to this manual, we also have a 15 minute demonstration video, which is probably a better place to start if you are new to EnvisioKnit.

Getting started

The Intro Screen

Larger

Intro Screen

When you start EnvisioKnit Design Studio, the first thing you will see is the intro screen. From here, you can choose to create a new design or open one that you've already started.

If it's been a while since you downloaded EnvisioKnit, there may be an update available. EnvisioKnit checks for updates every time it starts, so if there is one, a window will appear and ask if you'd like to update. The updater takes care of downloading and installing the new version automatically, but afterwards you will need to close EnvisioKnit and restart it to run the new version.

Creating a New Design

Larger

Create a New Chart

If you select to create a new design you will be prompted to create your initial chart.

You can enter the name of the chart, its size, gauge, and you can specify the yarn and stitch motif that will be used to fill the chart.

The size of the chart can be set either by entering the number of rows and columns, or by entering the height and width. If you enter rows and columns, the height and width fields will be calculated for you. Likewise, if you enter the height and width, the rows and columns will be calculated. The calculation is based on your gauge setting.

The available stitch motifs are stockinette (all knit), reverse stockinette (all purl), garter, moss, seed, rib and blank (all no-stitch).

You can add additional yarns to your design by clicking the Add New Yarn button. Additional yarns can also be added at any time later. To change the existing yarn, just double click on it, and the Yarn Studio window will appear. To remove a yarn from the design, select the yarn and click the 'X' icon that appears in the lower right of the yarn button.

Opening an Existing Design

Larger

Open a Design File

If you choose to open an existing design, you will get the typical Open File window, where you can select the EnvisioKnit design file you want to load. EnvisioKnit uses the file extension .ekd for design files.

The Main Window

Larger

The Main Window

Once you have a design open, you will see the main EnvisioKnit Design Studio window. At the top, you will notice a toolbar with three large buttons: Yarn, Charts and Pattern.

Navigation Bar

This is the Navigation bar. These buttons let you navigate through the elements of your design.

Yarn Navigation Button

Clicking the Yarn navigation button will allow you to add a new yarn or select one to edit.

Chart Navigation Button

Likewise, clicking the Charts button will let you add a new chart or select a chart to edit.

Pattern Navigation Button

The pattern button will open the pattern editor. You always have one pattern associated with your design.

Menu Bar

Above the Navigation toolbar you will find the Menu bar.

File Menu

The Menu bar contains the typical menus you are probably familiar with from other applications.

From the File menu, you can create a new design, open an existing design, close, save or print the current one, or exit the program.

Edit Menu

The Edit menu provides the usual editing commands: Undo, Redo, Cut, Copy and Paste.

Settings Menu

The Settings menu contains options to set the cable symbol style used for all your cable stitches and to set the fonts used in your current design (see Font Settings). It also has options for setting and clearing your default preferences (See Default Design Settings).

Tools Menu

The Tools menu has an Import tool that will allow you to bring charts, yarn and stitches from other design files into your current design. (see Importing).

Help Menu

The Help menu features a link to this Manual, which will open in your browser when you click on it. There is also a Check for Updates option that will check the website and let you know if there is an update available. The About EnvisioKnit page will simply tell you the version of the program.

Below the Navigation toolbar you will have your chart editor, which we will continue with in the next section.

Page 1 of 21 Next >>